技术流笔记:页面留言

来自技术流笔记
跳转至: 导航搜索
  • 2017年11月9日,西北高原在数据库说:数据库是各个系统中必不可少的东西
  • 2017年11月9日,西北高原在数据库说:我爱MySQL
  • 2017年11月9日,西北高原在人工生命说:这个有点。。。
  • 2017年11月9日,西北高原在人工生命说:出来就是颠覆
  • 2017年11月9日,西北高原在新手练习说:功能越来越完善
  • 2017年11月9日,西北高原在新手练习说:继续加油呢
  • 2017年11月10日,风华少年在用户:风华少年说:原来PhpStorm和PyCharm是一家公司的。
  • 2017年11月11日,风华少年在用户:风华少年说:搜狗上市以后,变得更加不要脸了。
  • 2017年12月2日,西北高原在留言板说:日积月累,积小流成江海
  • 2017年12月21日,Admin在Ubuntu下编译比特币说:master版本成功了,应该在0.15之上吧;0.12的成功了。

0.9的失败了。提示: /usr/include/boost/variant/get.hpp:178:5: error: invalid application of ‘sizeof’ to incomplete type ‘boost::STATIC_ASSERTION_FAILURE<false>’ BOOST_STATIC_ASSERT_MSG( ^

checking for z_zlibVersion in -lz... no configure: error: zlib not installed

make all-am make[1]: Entering directory `/c/deps/libpng-1.6.10' depbase=`echo png.lo | sed 's|[^/]*$|.deps/&|;s|\.lo$||'`;\ /bin/sh ./libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -g -O2 -MT png.lo - MD -MP -MF $depbase.Tpo -c -o png.lo png.c &&\ mv -f $depbase.Tpo $depbase.Plo libtool: compile: gcc -DHAVE_CONFIG_H -I. -g -O2 -MT png.lo -MD -MP -MF .deps/png.Tpo -c png.c -o p ng.o In file included from pngpriv.h:72:0, from png.c:14: pnglibconf.h:199:54: error: expected identifier or '(' before '-' token 0 ^ In file included from png.h:462:0, from pngpriv.h:290, from png.c:14: pngconf.h:544:9: error: unknown type name 'ptrdiff_t' typedef ptrdiff_t png_ptrdiff_t; ^2017年12月23日 (六) 18:44 (CST)Admin讨论) In file included from png.c:14:0: pngpriv.h:816:21: error: operator '!=' has no left operand

  1. if PNG_ZLIB_VERNUM != 0 && PNG_ZLIB_VERNUM != ZLIB_VERNUM

^~ make[1]: *** [png.lo] Error 1 make[1]: Leaving directory `/c/deps/libpng-1.6.10' make: *** [all] Error 2

  • 2017年12月28日,Admin在Linux_vi/vim使用方法说:摸索一晚上,就为修改几个字符,不过想想没有其他好办法,而这还是个办法,那么就治好忍了
  • 2017年12月31日,Admin在比特币0.9.2中文版编译手册说:这里需要先安装VC++的。 所以安装vs2010,设置了两个环境变量到path,分别是C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin;C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE;

libcode 暂时使用了1.6.10,主要配置时候的参数改变

  • 2017年12月31日,Admin在比特币0.9.2中文版编译手册说:QT版本使用了5.2.1版本,原来的教程也是东拼西凑,跟下面的路径版本相冲突,原来他也是用了5.2.1版本

在上面这个网址重新下载了qt5.2.1的base和tools包后,重新配置,隐隐有一种 要成功的感觉

另外前面每一步make之后,似乎还需要make install

  • 2019年3月14日,Admin在Discuz_X3.4配置https的教程说:试验了一下最新版的安装,即使使用https模式安装,安装完毕依然需要修改这些地方。